Sustituir router movistar 02 por Mikrotik

2023-10-09

Índice

  1. Dar de alta las Vlan
  2. Configurar la interfaz PPPoE
  3. Modificamos la lista WAN
  4. Referencia

Partimos del supuesto que tenemos ONT y router por separado o el router de la operadora en modo bridge

img

También siguiendo mi anterior articulo, partimos con la configuración que por defecto deja Mikrotik en su routers después de hacer un reset sin marcar la opción no default configuration.

img

El operador O2 utiliza los valores siguientes:

  • VLAN datos: ID 6 Prioridad 1
  • VLAN Voz: ID 3 Prioridad 4

Dar de alta las Vlan

Solo voy a configurar la VLAN para datos, ya que no tilizo el servicio de telefonia fija,

Empezamos, como nombre le voy a poner vlan6-internet, como VLAN-ID hemos dicho que O2 utiliza la 6, en mi router, Ax³3, el puerto físico para la WAN es el 1, así que selecciono como interface la ether1, gráficamente lo podemos configurar desde el menú Interfaces -> VLAN

img

img

Configurar la interfaz PPPoE

Configuramos la interfaz PPPoE para que use la VLAN 6, la identificamos con el nombre internet y le asignamos la interfaz vlan6-internet que acabamos de crear. Menú ppp -> Interface

img

En la pestaña Dial Out introducimos el usuario(adslppp@telefonicanetpa) y contraseña(adslppp) utilizados por 02

img

Modificamos la lista WAN

Dentro de Interfaces añadimos a la lista WAN el interface PPPoE (internet) para que el firewall/nat funcione correctamente.

img

Con esto ya habriamos terminaod de configurar el router.

Nota: por defecto ya viene creada la regla del firewall para enmascarar el tráfico, lo puedes comprobar

img

img

Te dejo también el script por si quieres realizar todo el procesos desde el terminal del router

    # Dar de alta la vlan de internet. Suponemos ONT/Router bridge en ether1
    /interface/vlan
    add interface=ether1 name=vlan6-internet vlan-id=6
    
    # Configurar la interfaz PPPoE para que use la vlan de internet
    /interface/pppoe-client
    add add-default-route=yes disabled=no interface=vlan6-internet \
      name=internet use-peer-dns=yes user=adslppp@telefonicanetpa \
      password=adslppp
    
    # Modificamos la lista WAN con la nueva interfaz de acceso a internet,
    # para que apliquen correctamente las reglas de Firewall / NAT sobre ella
    /interface/list/member
    set [find where interface=ether1 and list=WAN] interface=internet

Espero que te haya gustado, pasa un gran día 🐧

Referencia

https://foro.adslzone.net/mikrotik.199/manual-mikrotik-configuraciones-basicas-isps-routeros-v7.580707/


Ingrese la dirección de su instancia


Más publicaciones como este

Configurar router Mikrotik y Pi-Hole

2024-04-08 | #pihole #router

Si disponemos de un servidor Pi-Hole trabajando en nuestra red podemos configurar nuestro router Mikrotik para que todos los dispositivos que se conecten a él utilicen Pi-Hole como servidor DNS en vez de tener que ir configurando cada dispositivo uno a uno.

Continuar leyendo 